manjaro吧 关注:2,574贴子:7,344
  • 1回复贴,共1

qBittorrent version: v4.1.3 Ar

只看楼主收藏回复

qBittorrent version: v4.1.3 Arcolinux18.10.4,今天已经进行滚动更新,在昨天滚动更新至后出现了qBittorrent无法启动的问题;
QT版本 5.11.2 libtorrent 1:1.1.10-1
出现的以下问题
Caught signal: SIGSEGV
Stack trace:
/usr/lib/libQt5Network.so.5 : ()+0x9aca4 [0x7fdcc7c72ca4]
/usr/lib/libQt5Network.so.5 : ()+0x9959b [0x7fdcc7c7159b]
/usr/lib/libQt5Core.so.5 : QObject::event(QEvent*)+0xe2 [0x7fdcc7933352 ]
/usr/lib/libQt5Widgets.so.5 : QApplicationPrivate::notify_helper(QObject*, QEvent*)+0x84 [0x7fdcc84f6e14]
/usr/lib/libQt5Widgets.so.5 : QApplication::notify(QObject*, QEvent*)+0x211 [0x7fdcc84fe6e1]
qbittorrent : Application::notify(QObject*, QEvent*)+0x23 [0x55d9f0b97b43]
/usr/lib/libQt5Core.so.5 : QCoreApplication::notifyInternal2(QObject*, QEvent*)+0x179 [0x7fdcc7908c39]
/usr/lib/libQt5Core.so.5 : QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*)+0x1dc [0x7fdcc790bccc]
/usr/lib/libQt5Core.so.5 : ()+0x2c59d4 [0x7fdcc795c9d4]
/usr/lib/libglib-2.0.so.0 : g_main_context_dispatch()+0x2bf [0x7fdcc659f3cf]
/usr/lib/libglib-2.0.so.0 : ()+0x6cf89 [0x7fdcc65a0f89]
/usr/lib/libglib-2.0.so.0 : g_main_context_iteration()+0x2e [0x7fdcc65a0fce]
/usr/lib/libQt5Core.so.5 : QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x69 [0x7fdcc795bfc9]
/usr/lib/libQt5Core.so.5 : QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)+0x13c [0x7fdcc79078cc]
/usr/lib/libQt5Core.so.5 : QThread::exec()+0xb9 [0x7fdcc7750eb9]
/usr/lib/libQt5Core.so.5 : ()+0xc3f65 [0x7fdcc775af65]
/usr/lib/libpthread.so.0 : ()+0x7a9d [0x7fdcc767da9d]
/usr/lib/libc.so.6 : clone()+0x43 [0x7fdcc727db23]
[1] 2232 segmentation fault (core dumped) qbittorren
Arch论坛里有类似的问题,旧版本出现了同样问题与原因是lxqt模块需要进行重新构建,临时解决方法是IPfilter/Enable=false,亲测无效
github给出了其他的临时解决方式:挂代理、或打开设置选项,亲次无用
个人发现的临时解决方式有两个:或者以管理员权限运行或者删除~/.config/qBittorrent(每次打开均需删除)
求问改如何解决问题


回复
来自Android客户端1楼2018-10-25 01:18