为知笔记吧 关注:8,519贴子:64,872
  • 6回复贴,共1

Ubuntu 14.04安装Linux 2.5.8 绿色版(AppImage) 问题

只看楼主收藏回复

Ubuntu 14.04,官网下载Linux 2.5.8 绿色版(AppImage),使用以下命令安装
```
sudo chmod 777 WizNote-2.5.8-x86_64.AppImage
./WizNote-2.5.8-x86_64.AppImage
```
出现错误信息,如下:
```
./WizNote-2.5.8-x86_64.AppImage: /lib/x86_64-linux-gnu/libgpg-error.so.0: no version information available (required by /tmp/.mount_WizNotFvGWBp/WizNote/bin/../lib/libgcrypt.so.20)
./WizNote-2.5.8-x86_64.AppImage: relocation error: /tmp/.mount_WizNotFvGWBp/WizNote/bin/../lib/libboost_system.so.1.58.0: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEED1Ev, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
```
请问如何解决?
谢谢!


回复
1楼2018-03-12 21:06
    大家没有遇到这个问题么?


    回复(3)
    2楼2018-03-13 18:32
      运行strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBC,查看GLIBC版本到3.4.xx多少
      升级g++,
      然后重新运行strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBC,查看GLIBC版本,我当初装g++4.8.5后,效果变成这样
      GLIBCXX_3.4
      GLIBCXX_3.4.1
      GLIBCXX_3.4.2
      GLIBCXX_3.4.3
      GLIBCXX_3.4.4
      GLIBCXX_3.4.5
      GLIBCXX_3.4.6
      GLIBCXX_3.4.7
      GLIBCXX_3.4.8
      GLIBCXX_3.4.9
      GLIBCXX_3.4.10
      GLIBCXX_3.4.11
      GLIBCXX_3.4.12
      GLIBCXX_3.4.13
      GLIBCXX_3.4.14
      GLIBCXX_3.4.15
      GLIBCXX_3.4.16
      GLIBCXX_3.4.17
      GLIBCXX_3.4.18
      GLIBCXX_3.4.19
      GLIBCXX_3.4.20
      GLIBCXX_3.4.21
      GLIBCXX_3.4.22
      GLIBCXX_3.4.23
      GLIBCXX_3.4.24
      GLIBC_2.2.5
      GLIBC_2.3
      GLIBC_2.14
      GLIBC_2.4
      GLIBC_2.18
      GLIBC_2.16
      GLIBC_2.3.4
      GLIBC_2.17
      GLIBC_2.3.2
      GLIBCXX_DEBUG_MESSAGE_LENGTH


      然后打开运行为知笔记,还是会报:version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
      最后sudo find / -name "libstdc++.so*"搜索了一下,刚好找到一个libstdc++.so.6.0.21文件,然后cp到/usr/lib/x86_64-linux-gnu/,然后删掉原来的libstdc++.so.6,重新链接sudo ln -s libstdc++.so.6.0.21 libstdc++.so.6。最终还是运行起来了,但是中文问题解决不了,即便是这样搞,我有时候重启机子,运行为知笔记,还是会报version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference,然后我又老步骤再链接了一遍。又可以了。真是麻烦的要死


      回复
      3楼2018-03-20 10:39

        扫二维码下载贴吧客户端

        下载贴吧APP
        看高清直播、视频!