pt吧 关注:159,072贴子:8,828,796

回复:debian7安装编译qb

只看楼主收藏回复

然后给qmake添加环境变量:vi /etc/profile,添加一行PATH="/opt/Qt5.9.2/5.9.2/gcc_64/bin":$PATH


收起回复
来自Android客户端16楼2018-02-28 16:26
    查看一下版本ldd--version,如果是2.14以上的话一般不会报上面那个错误


    收起回复
    来自Android客户端18楼2018-02-28 16:29
      下载源码包:wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz并解压它


      收起回复
      来自Android客户端19楼2018-02-28 16:30
        进入解压后的目录并且新建一个目录然后进入它cd glibc-2.14
        mkdir build
        cd build


        回复
        来自Android客户端20楼2018-02-28 16:35
          ../configure --prefix=/opt/glibc-2.14 // 配置glibc并设置当前glibc-2.14安装目录


          回复
          来自Android客户端21楼2018-02-28 16:38
            make && make install// 编译安装glibc-2.14库


            回复
            来自Android客户端22楼2018-02-28 16:38
              安装完成后, 建立软链指向glibc-2.14(这里很危险!如果出了问题楼主概不负责!不想弄这部分的可以安装debian8)


              回复
              来自Android客户端23楼2018-02-28 16:39
                被吞楼了。。。。


                回复
                来自Android客户端27楼2018-02-28 16:41
                  发不出去了。。


                  回复
                  来自Android客户端38楼2018-02-28 16:56
                    发图吧


                    回复
                    来自Android客户端39楼2018-02-28 16:58
                      然后qmake就可以用了,开始编译qb


                      回复
                      来自Android客户端40楼2018-02-28 16:59
                        返回qb的解压目录,./configure


                        回复
                        来自Android客户端41楼2018-02-28 17:00
                          编译:make ,然后安装make install


                          回复
                          来自Android客户端42楼2018-02-28 17:01
                            完成。到这里我们可以看到,主要是因为依赖包很难装,可能还需要libtorrent但我没碰到这个错误所以没管。找了很多地方都没有具体的安装方法,所以我就写了一个,如有错误请指出


                            回复
                            来自Android客户端43楼2018-02-28 17:03
                              收起回复
                              44楼2018-02-28 17:07