为知笔记吧 关注:9,445贴子:70,575

更新 | Mac 2.5.8 版本更新 & Linux 2.5.8 绿色版(AppImage)

只看楼主收藏回复

Mac 版 2.5.8 下载地址:http://url.wiz.cn/u/mac


Linux 版 2.5.8 下载地址:https://url.wiz.cn/u/Wizlinux
下载后标记为可执行:命令行运行 chmod a+x WizNote-x86_64.AppImage 或者文件 属性里面选择可执行
* 该版本可使用搜狗输入法直接输入中文,在 Ubuntu 16.4 和 17.01上测试通过,如果其他发行版本无法输入中文,可参考帖子末尾的方法,并将***作系统版本、输入法版本反馈给我们,谢谢。




更新日志:
新增合并笔记功能
新增双击笔记中的图片可查看原图功能
新增导出为 md 格式
优化笔记中超链接菜单,新增移除链接地址功能
优化:点击回收站,可直接打开回收站页面
新增鼠标指针移至附件上可显示完整附件名称
修复复制图片粘贴后图片异常的问题
修复导出为 PDF 后文件标题不是笔记标题的问题
修复在有序列表中插入代码,导致序号重新开始的问题
修复 Markdown 笔记导出 html 后不渲染的问题
修复删除笔记中的图片,本地数据中的图片没删除的问题
修复了标题中含有尖括号的笔记出现在搜索结果中时,尖括号中内容消失的问题
修复了由于设置样式导致代码段中出现多余代码的问题
修复了在Markdown表格中使用列表语法渲染异常的问题
修复了一些编辑方面的小问题


编译安装后无法输入中文的解决方案:
在Ubuntu中编译的WizNote不能输入中文,原因是fcitx需要支持Qt5
解决方法:编译安装fcitx-qt5
依赖:sudo apt install cmake extra-cmake-modules fcitx-libs-dev
设置 qmake 环境变量:export PATH="/home/cedar/Qt5.7.0/5.7/gcc_64/bin":$PATH


编译fcitx-qt5:
git clone https://github.com/fcitx/fcitx-qt5.git
cd fcitx-qt5
cmake .
make
sudo make install

最后把编译得到 libfcitxplatforminputcontextplugin.so 拷贝到 Qt5.7安装目录的 Tools/QtCreator/lib/Qt/plugins/platforminputcontexts


回复
1楼2018-01-15 15:22
    楼主,linux绿色版链接打不开。请楼主查看


    收起回复
    2楼2018-01-15 22:51
      已下载,目前正常使用。
      appimage格式,非常方便,下载后,将文件添加可执行属性就可以运行了。如果能生成菜单配置文件和图标,就完美了。
      不过,为知笔记可以提供个 图标文件 和 菜单配置文件desktop模板,让用户自己修改下。


      回复
      3楼2018-01-16 17:06
        什么时候MAC版本能出皮肤啊。。一直是白色一片,粗糙的很


        回复
        4楼2018-01-17 10:21
          对于Linux这次的改进,必须点赞!!!


          回复
          5楼2018-01-17 11:58
            说个问题吧,mac版本更新之后,因为我会员失效了,电脑右上角隔一会就一直弹出来一个网络失败的框,这个真的是烦死了,逼着我再买会员。但是我现在工作用的是自己电脑,不需要买会员啊


            回复
            7楼2018-01-18 14:27
              强迫症真的是烦的不行,经常被右上角弹出的弹窗打断。买了会员


              回复
              9楼2018-01-18 14:38
                2.5.8 MAC版 更新后,新增笔记会无法上传,会遗失内容,但无报错!操作如下:
                1) 新增笔记
                2) 复制网页内容,並貼到笔记内
                3) 进入阅读模式并同步
                4) 点击其他笔记再回到这次新增的笔记,内容已经遗失,但标题还在,就是内容一片空白。
                5) 使用手机端同步,试图寻找刚刚新增的笔记,结果一样只有标题没有内容!


                连续测试几次都是这样,后来回复到2.5.7版就正常了!


                回复
                11楼2018-01-19 13:43
                  Linux版中,小小输入法无法使用。
                  编译了小小输入法的QT5插件,也是不能用。


                  回复
                  12楼2018-01-19 19:41
                    Running "/usr/bin/cmake -E server --pipe=/tmp/cmake-VQi0qn/socket --experimental" in /home/i5/Documents/wiz/Debug.
                    The C compiler identification is GNU 6.4.0
                    The CXX compiler identification is GNU 6.4.0
                    Check for working C compiler: /usr/bin/gcc
                    Check for working C compiler: /usr/bin/gcc -- works
                    Detecting C compiler ABI info
                    Detecting C compiler ABI info - done
                    Detecting C compile features
                    Detecting C compile features - done
                    Check for working CXX compiler: /usr/bin/g++
                    Check for working CXX compiler: /usr/bin/g++ -- works
                    Detecting CXX compiler ABI info
                    Detecting CXX compiler ABI info - done
                    Detecting CXX compile features
                    Detecting CXX compile features - done
                    Performing Test COMPILER_SUPPORTS_CXX11
                    Performing Test COMPILER_SUPPORTS_CXX11 - Success
                    Performing Test COMPILER_SUPPORTS_CXX0X
                    Performing Test COMPILER_SUPPORTS_CXX0X - Success
                    Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8")
                    /home/i5/Documents/wiz/WizQTClient/resources/wiznote.qrc
                    WizNote whill compiling as Debug, use Qt: 5.9.0
                    Configuring done
                    Generating done
                    CMake Warning:
                    Manually-specified variables were not used by the project:


                    QT_QMAKE_EXECUTABLE


                    这个 『QT_QMAKE_EXECUTABLE』报错怎么消除?


                    回复
                    13楼2018-01-20 13:46
                      好吧,消除了这个警告,还是有问题:


                      回复
                      14楼2018-01-20 14:21
                        Running "/usr/bin/cmake -E server --pipe=/tmp/cmake-uXGmIU/socket --experimental" in /tmp/QtCreator-aCpgtx/qtc-cmake-XXBTXN5d.
                        The C compiler identification is GNU 6.4.0
                        The CXX compiler identification is GNU 6.4.0
                        Check for working C compiler: /usr/bin/gcc
                        Check for working C compiler: /usr/bin/gcc -- works
                        Detecting C compiler ABI info
                        Detecting C compiler ABI info - done
                        Detecting C compile features
                        Detecting C compile features - done
                        Check for working CXX compiler: /usr/bin/g++
                        Check for working CXX compiler: /usr/bin/g++ -- works
                        Detecting CXX compiler ABI info
                        Detecting CXX compiler ABI info - done
                        Detecting CXX compile features
                        Detecting CXX compile features - done
                        Performing Test COMPILER_SUPPORTS_CXX11
                        Performing Test COMPILER_SUPPORTS_CXX11 - Success
                        Performing Test COMPILER_SUPPORTS_CXX0X
                        Performing Test COMPILER_SUPPORTS_CXX0X - Success
                        Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8")
                        /home/i5/Documents/wiz/WizQTClient/resources/wiznote.qrc
                        WizNote whill compiling as Debug, use Qt: 5.9.0
                        Configuring done
                        Generating done


                        编译出来的客户端,无法使小小输入法。


                        回复
                        15楼2018-01-20 14:22
                          楼主,Linux绿色版无法登录,提示network error,但是我网络是正常的呀


                          收起回复
                          16楼2018-01-21 01:52
                            点赞,但是这个包在centos下运行有依赖问题,可不可以提供一个centos7下的打包文件?


                            回复
                            17楼2018-01-22 15:45
                              分享我编译的为知笔记:


                              可以支持小小输入法了现在


                              https://pan.stnts.com/s/LvJRqln


                              收起回复
                              18楼2018-01-24 00:23