gamemaker吧 关注:13,241贴子:91,175

【教程】GMS连接Linux虚拟机教程

只看楼主收藏回复

成功图镇楼(我又拿了湖大的范例实验了


回复
1楼2015-11-18 21:45
    等下开始教程(等我拿到电脑


    回复
    来自iPhone客户端2楼2015-11-18 21:50
      好了,现在开坑


      回复
      4楼2015-11-19 17:28
        首先你需要一个虚拟机软件,VMWare家的或者Vbox等可以使用NAT和DHCP的虚拟机都可以,但主机内存最好4G以上,64位系统,否则卡出翔不要怪我


        回复
        5楼2015-11-19 17:30
          如果你用的是vmware player的话弹出这个写邮箱就能用了


          回复
          6楼2015-11-19 17:34
            然后你需要一个Linux系统ISO镜像,这里我用的是Ubuntu 14.04 LTS系统ISO
            如果只是测试游戏和导出游戏32位ISO镜像就行


            收起回复
            7楼2015-11-19 17:37
              至于怎么装就可以忽略了吧
              这是我设置的Ubuntu虚拟机配置(个人感觉完全够用)


              回复
              8楼2015-11-19 17:40
                我已经装好了,安装过程忽略


                回复
                9楼2015-11-19 17:43
                  我特地去看了官方的帮助文档,你需要装一堆运行库才能在GMS配置Linux,这是官方文档地址:http://help.yoyogames.com/entries/93994668-Setup-Ubuntu-And-GameMaker-Studio-For-Linux-Development


                  收起回复
                  10楼2015-11-19 18:03
                    在安装之前先配置好软件源


                    回复
                    11楼2015-11-19 18:07
                      找到中国(英文系统找China)

                      随便选一个,163,阿里云,搜狐的都可以


                      回复
                      12楼2015-11-19 18:09
                        选完了会让你输入密码,把你设置的密码输进去就行


                        回复
                        13楼2015-11-19 18:10
                          在桌面按Ctrl+Alt+T打开终端,输入
                          sudo apt-get update
                          更新下软件源(root用户可以不用打sudo)
                          这里输入你设置的密码,回车


                          回复
                          14楼2015-11-19 18:15
                            等它走完


                            回复
                            15楼2015-11-19 18:16
                              现在就是安装成堆的运行库了,继续在终端输入(root用户去掉sudo):
                              sudo apt-get install openssh-client
                              sudo apt-get install openssh-server
                              sudo apt-get install libopenal1
                              sudo apt-get install libopenal1:i386
                              sudo apt-get install lib32z1
                              sudo apt-get install lib32ncurses5
                              sudo apt-get install lib32bz2-1.0
                              sudo apt-get install libstdc++6:i386
                              sudo apt-get install libxxf86vm1
                              sudo apt-get install libssl1.0.0:i386
                              sudo apt-get install libglu1:i386
                              sudo apt-get install libxrandr-dev
                              sudo apt-get install libxrandr2:i386


                              如果要有YYC库的可以继续输入:
                              sudo apt-get install clang
                              sudo apt-get install libc6-dev-i386
                              sudo apt-get install libcurl3:i386
                              sudo apt-get install libssl-dev:i386
                              按照官方文档是这样,不过实测Ubuntu 14.04 LTS有几个库已经预装了或者是最新版本可以忽略掉(不过我忘了是哪几个了
                              如果你用的是Ubuntu 12.04 LTS版本则这些都要装


                              收起回复
                              16楼2015-11-19 18:22